Improper Certificate Validation Affecting edu.vt.middleware:vt-ldap package, versions [3.3.5, 3.3.8)


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High
Expand this section
NVD
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-EDUVTMIDDLEWARE-30091
  • published 25 Dec 2016
  • disclosed 10 Sep 2014
  • credit Unknown

How to fix?

Upgrade edu.vt.middleware:vt-ldap to version 3.3.8 or higher.

Overview

edu.vt.middleware:vt-ldap is a Library for performing common LDAP operations.

Affected versions of this package are vulnerable to Improper Certificate Validation. It was discovered that the implementation used by the vtldap/ldaptive project to check that the server hostname matches the domain name in the subject's CN field was flawed. This can be exploited by a Man-in-the-middle (MITM) attack, where the attacker can spoof a valid certificate using a specially crafted subject.