Man-in-the-Middle (MitM) Affecting io.arrow-kt:arrow-ank-gradle package, versions [,0.9.0)


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOARROWKT-1291016

  • published

    12 May 2021

  • disclosed

    22 Apr 2019

  • credit

    Unknown

How to fix?

Upgrade io.arrow-kt:arrow-ank-gradle to version 0.9.0 or higher.

Overview

io.arrow-kt:arrow-ank-gradle is a Compile time docs verification and evaluation for Kotlin and Java

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM). It resolved Gradle build artifacts (for compiling and building the published JARs) over HTTP instead of HTTPS.