Remote Code Execution (RCE) Affecting io.dropwizard:dropwizard-validation Open this link in a new tab package, versions [1.3.0-rc1,1.3.19) [2.0.0,2.0.2)


0.0
high
  • Attack Complexity

    High

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IODROPWIZARD-552147

  • published

    24 Feb 2020

  • disclosed

    24 Feb 2020

  • credit

    Unknown

How to fix?

Upgrade io.dropwizard:dropwizard-validation to version 1.3.19, 2.0.2 or higher.

Overview

io.dropwizard:dropwizard-validation is a simple library for building production-ready RESTful web services.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). An attacker is able to inject arbitrary Java Expression Language expressions when using the self-validating feature.