0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOFABRIC8PIPELINE-469198

  • published

    26 Sep 2019

  • disclosed

    25 Sep 2019

  • credit

    Jesse Glick, CloudBees, Inc.

How to fix?

There is no fixed version for io.fabric8.pipeline:kubernetes-pipeline-arquillian-steps.

Overview

io.fabric8.pipeline:kubernetes-pipeline-arquillian-steps is a Kubernetes Pipeline Arquillian Steps Jenkins plugin.

Affected versions of this package are vulnerable to Sandbox Bypass. The plugin was found to provide a custom whitelist for script security that allowed attackers to invoke arbitrary methods, bypassing typical sandbox protection.

References