Information Exposure Affecting io.jenkins:configuration-as-code package, versions [,1.25)


0.0
low

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-IOJENKINS-456239
  • published 1 Aug 2019
  • disclosed 31 Jul 2019
  • credit Unknown

How to fix?

Upgrade io.jenkins:configuration-as-code to version 1.25 or higher.

Overview

io.jenkins:configuration-as-code is a plugin for configuring Jenkins based on human-readable declarative configuration files.

Affected versions of this package are vulnerable to Information Exposure due to proxy password not being treated as a secret to be masked when logging or encrypted for export.