Authentication Bypass Affecting io.jenkins.blueocean:blueocean-bitbucket-pipeline Open this link in a new tab package, versions [,1.1.6)


0.0
high
  • Attack Complexity

    Low

  • Scope

    Changed

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOJENKINSBLUEOCEAN-32225

  • published

    25 Apr 2018

  • disclosed

    7 Aug 2017

  • credit

    Cliff Meyers

How to fix?

Upgrade io.jenkins.blueocean:blueocean-bitbucket-pipeline to version 1.1.6 or higher.

Overview

io.jenkins.blueocean:blueocean-bitbucket-pipeline is a reboot of the Jenkins CI/CD User Experience.

Affected versions of this package are vulnerable to Authentication Bypass. It allowed users with read access to the GitHub organization folder to create arbitrary commits in the repositories inside the GitHub organization corresponding to the GitHub organization folder with the GitHub credentials of the creator of the organization folder. Additionally, users with read access to the GitHub organization folder could read arbitrary file contents from the repositories inside the GitHub organization.