Insecure Permissions Affecting io.jenkins.plugins:warnings-ng Open this link in a new tab package, versions [,8.5.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOJENKINSPLUGINS-1087422

  • published

    19 Mar 2021

  • disclosed

    19 Mar 2021

  • credit

    Daniel Beck of CloudBees Inc.

How to fix?

Upgrade io.jenkins.plugins:warnings-ng to version 8.5.0 or higher.

Overview

io.jenkins.plugins:warnings-ng is a collects compiler warnings or issues reported by static analysis tools and visualizes the results.

Affected versions of this package are vulnerable to Insecure Permissions. Warnings Next Generation Plugin 8.4.4 and earlier does not perform permission checks in methods implementing form validation.This allows attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents. A sequence of requests can be used to effectively list workspace contents.