Insufficiently Protected Credentials Affecting io.jenkins.plugins:neuvector-vulnerability-scanner package, versions [,1.6)


0.0
low

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.04% (11th percentile)
Expand this section
NVD
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-IOJENKINSPLUGINS-469192
  • published 26 Sep 2019
  • disclosed 25 Sep 2019
  • credit Unknown

How to fix?

Upgrade io.jenkins.plugins:neuvector-vulnerability-scanner to version 1.6 or higher.

Overview

io.jenkins.plugins:neuvector-vulnerability-scanner is a Jenkins plugin that adds NeuVector registry and image scanning as a build step.

Affected versions of this package are vulnerable to Insufficiently Protected Credentials. The plugin stores credentials unencrypted in its global configuration file on the Jenkins master where they could be viewed by users with access to the master file system.

References