Predictable Exact Value from Previous Values Affecting io.ktor:ktor-utils Open this link in a new tab package, versions [,2.0.1)


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOKTOR-2823334

  • published

    12 May 2022

  • disclosed

    12 May 2022

  • credit

    Unknown

How to fix?

Upgrade io.ktor:ktor-utils to version 2.0.1 or higher.

Overview

Affected versions of this package are vulnerable to Predictable Exact Value from Previous Values in the SHA1 implementation, which was returning the same value after hashing.