Information Exposure Affecting io.ktor:ktor-client-core package, versions [,1.3.0-rc)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOKTOR-548684

  • published

    13 Feb 2020

  • disclosed

    13 Feb 2020

  • credit

    Unknown

How to fix?

Upgrade io.ktor:ktor-client-core to version 1.3.0-rc or higher.

Overview

io.ktor:ktor-client-core is a framework for quickly creating web applications in Kotlin with minimal effort.

Affected versions of this package are vulnerable to Information Exposure. The client package within Ktor resends data from the HTTP Authorization header to a redirect location.

References