Remote Code Execution (RCE) Affecting io.kubernetes:client-java-parent Open this link in a new tab package, versions [12.0.0,12.0.1) [,11.0.2)


0.0
medium
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOKUBERNETES-1294542

  • published

    19 May 2021

  • disclosed

    17 May 2021

  • credit

    Jordy Versmissen

How to fix?

Upgrade io.kubernetes:client-java-parent to version 12.0.1, 11.0.2 or higher.

Overview

io.kubernetes:client-java-parent is a Kubernetes Client Library.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). Loading specially-crafted yaml can lead to code execution.