Insecure Defaults Affecting io.netty:netty-handler Open this link in a new tab package, versions [,4.0.45.Final) [4.1.0.Beta1,4.1.9.Final)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IONETTY-31515

  • published

    20 Sep 2017

  • disclosed

    16 Feb 2017

  • credit

    Unknown

Overview

io.netty:netty is a NIO client server framework which enables quick and easy development of network applications such as protocol servers and clients.

Affected version of this package did not properly ensure that the certificate is actually associated with that host.

Remediation

Upgrade netty to versions 4.0.45, 4.1.9 or higher.

References