HTTP Request Smuggling Affecting io.netty:netty-codec-http package, versions [,4.1.44.Final)


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IONETTY-543669

  • published

    30 Jan 2020

  • disclosed

    29 Jan 2020

  • credit

    Zeddy

How to fix?

Upgrade io.netty:netty-codec-http to version 4.1.44.Final or higher.

Overview

io.netty:netty-codec-http is a network application framework for rapid development of maintainable high performance protocol servers & clients.

Affected versions of this package are vulnerable to HTTP Request Smuggling. It allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax or as an "invalid fold."