Username Enumeration Affecting io.openliberty:openliberty-runtime package, versions [17.0.0.3,21.0.0.10)


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-IOOPENLIBERTY-1586047
  • published 17 Sep 2021
  • disclosed 17 Sep 2021
  • credit Unknown

How to fix?

Upgrade io.openliberty:openliberty-runtime to version 21.0.0.10 or higher.

Overview

io.openliberty:openliberty-runtime is a dynamic application server runtime environment.

Affected versions of this package are vulnerable to Username Enumeration. Liberty could allow a remote user to enumerate usernames due to a difference of responses from valid and invalid login attempts.