Information Exposure Affecting io.quarkus:quarkus-vertx-http Open this link in a new tab package, versions [,1.5.2.Final)


0.0
low
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOQUARKUS-572492

  • published

    2 Jul 2020

  • disclosed

    16 Jun 2020

  • credit

    hyperman1

Introduced: 16 Jun 2020

CWE-200 Open this link in a new tab

How to fix?

Upgrade io.quarkus:quarkus-vertx-http to version 1.5.2.Final or higher.

Overview

io.quarkus:quarkus-vertx-http is a Cloud Native, (Linux) Container First framework for writing Java applications.

Affected versions of this package are vulnerable to Information Exposure. The debug log dumps Basic authentication credentials in plaintext.

References