Insecure Defaults Affecting io.ratpack:ratpack-session Open this link in a new tab package, versions [,1.9.0)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IORATPACK-1315141

  • published

    30 Jun 2021

  • disclosed

    30 Jun 2021

  • credit

    Jonathan Leitschuh

How to fix?

Upgrade io.ratpack:ratpack-session to version 1.9.0 or higher.

Overview

io.ratpack:ratpack-session is a that allows supports for HTTP sessions within Ratpack applications.

Affected versions of this package are vulnerable to Insecure Defaults. The default configuration of client side sessions results in unencrypted, but signed, data being set as cookie values. This means that if something sensitive goes into the session, it could be read by something with access to the cookies.