Information Exposure Affecting io.smallrye.config:smallrye-config Open this link in a new tab package, versions [,1.6.2)


0.0
medium
  • Attack Complexity

    High

  • Privileges Required

    High

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOSMALLRYECONFIG-548898

  • published

    17 Feb 2020

  • disclosed

    13 Feb 2020

  • credit

    Unknown

How to fix?

Upgrade io.smallrye.config:smallrye-config to version 1.6.2 or higher.

Overview

io.smallrye.config:smallrye-config is a SmallRye implementation of Eclipse MicroProfile Config

Affected versions of this package are vulnerable to Information Exposure. The API can allow other code running within the application server to potentially obtain the ClassLoader, bypassing any permissions checks that should have been applied. The largest threat from this vulnerability is a threat to data confidentiality.