NULL Pointer Dereference Affecting io.undertow:undertow-servlet Open this link in a new tab package, versions [0,2.0.34.Final) [2.1.0.Final,2.1.6.Final) [2.2.0.Final,2.2.4.Final)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOUNDERTOW-1053957

  • published

    26 Feb 2021

  • disclosed

    22 Dec 2020

  • credit

    Moulali Shikalwadi

Introduced: 22 Dec 2020

CWE-476 Open this link in a new tab

How to fix?

Upgrade io.undertow:undertow-servlet to version 2.0.34.Final, 2.1.6.Final, 2.2.4.Final or higher.

Overview

io.undertow:undertow-servlet is a Servlet 4.0 implementation for Undertow

Affected versions of this package are vulnerable to NULL Pointer Dereference. NullPointerException occurred if a servlet calls HttpServletRequest#getContextPath() while EAP was shutting down.