HTTP Request Smuggling Affecting io.undertow:undertow-core package, versions [2.0.30.SP4, 2.0.34.Final) [2.1.0, 2.1.6.Final)


0.0
medium

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
4.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-IOUNDERTOW-1070551
  • published 8 Feb 2021
  • disclosed 4 Feb 2021
  • credit Pedro Sampaio

How to fix?

Upgrade io.undertow:undertow-core to version 2.0.34.Final, 2.1.6.Final or higher.

Overview

io.undertow:undertow-core is a Java web server based on non-blocking IO.

Affected versions of this package are vulnerable to HTTP Request Smuggling. A regression issue reintroduced undertow's fix for CVE-2020-10687.

References