Information Exposure Affecting jenkins.xtc:extensivetesting Open this link in a new tab package, versions [0,]


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-JENKINSXTC-473890

  • published

    20 Oct 2019

  • disclosed

    16 Oct 2019

  • credit

    David Fiser

How to fix?

There is no fixed version for jenkins.xtc:extensivetesting.

Overview

jenkins.xtc:extensivetesting is a plugin that allows you to run eXtensive Testing tests before or after a build.

Affected versions of this package are vulnerable to Information Exposure. It stores credentials unencrypted in job config.xml files on the Jenkins master where they can be viewed by users with Extended Read permission, or access to the master file system.