Privilege Escalation Affecting net.sf.robocode:robocode package, versions [,1.9.3.6)


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-NETSFROBOCODE-174039

  • published

    30 Mar 2019

  • disclosed

    30 Mar 2019

  • credit

    Unknown

How to fix?

Upgrade net.sf.robocode:robocode to version 1.9.3.6 or higher.

Overview

net.sf.robocode:robocode is a programming game, where the goal is to develop a robot battle tank to battle against other tanks in Java or .NET. The robot battles are running in real-time and on-screen.

Affected versions of this package are vulnerable to Privilege Escalation. An attacker could cause external service interaction (DNS), as demonstrated by a query for a unique subdomain name within an attacker-controlled DNS zone, because of a .openStream call within java.net.URL.

References