Cross-site Request Forgery (CSRF) Affecting org.6wind.jenkins:lockable-resources package, versions [,2.9-rc303.11ea53b66dcb)

  • Attack Complexity


  • User Interaction


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    24 Sep 2020

  • disclosed

    24 Sep 2020

  • credit

    Pierre Beitz, CloudBees, Inc.

How to fix?

Upgrade org.6wind.jenkins:lockable-resources to version 2.9-rc303.11ea53b66dcb or higher.


org.6wind.jenkins:lockable-resources is an allows defining lockable resources (such as printers, phones, computers, etc.) that can be used by builds.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). Lockable Resources Plugin 2.8 and earlier does not require POST requests for several HTTP endpoints, resulting in a cross-site request forgery (CSRF) vulnerability.This vulnerability allows attackers to reserve, unreserve, unlock, and reset resources.Lockable Resources Plugin 2.9 requires POST requests for the affected HTTP endpoints.