Access Control Bypass Affecting org.apache.activemq:artemis-openwire-protocol Open this link in a new tab package, versions [,2.16.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEACTIVEMQ-1065976

  • published

    28 Jan 2021

  • disclosed

    28 Jan 2021

  • credit

    Francesco Marchioni

How to fix?

Upgrade org.apache.activemq:artemis-openwire-protocol to version 2.16.0 or higher.

Overview

org.apache.activemq:artemis-openwire-protocol is a package for activemq.

Affected versions of this package are vulnerable to Access Control Bypass. It was found that the creation of advisory messages in the OpenWire protocol head of Apache ActiveMQ Artemis bypassed policy based access control for the entire session. Production of advisory messages was not subject to access control in error.