Improper Authentication Affecting org.apache.activemq:activemq-broker Open this link in a new tab package, versions [,5.15.12)


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEACTIVEMQ-674315

  • published

    11 Sep 2020

  • disclosed

    11 Sep 2020

  • credit

    Jonathan Gallimore & Colm O hEigeartaigh

How to fix?

Upgrade org.apache.activemq:activemq-broker to version 5.15.12 or higher.

Overview

org.apache.activemq:activemq-broker is a high performance Apache 2.0 licensed Message Broker and JMS 1.1 implementation.

Affected versions of this package are vulnerable to Improper Authentication. Apache ActiveMQ uses LocateRegistry.createRegistry() to create the JMX RMI registry and binds the server to the jmxrmi entry. It is possible to connect to the registry without authentication and call the rebind method to rebind jmxrmi to something else. If an attacker creates another server to proxy the original, and bound that, he effectively becomes a man in the middle and is able to intercept the credentials when an user connects. Upgrade to Apache ActiveMQ 5.15.12.