XML External Entity (XXE) Injection Affecting org.apache.camel:camel-core package, versions (,2.13.3] [2.14.0,2.14.1]


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHECAMEL-30005

  • published

    17 Mar 2015

  • disclosed

    17 Mar 2015

  • credit

    Stephan Siano

Overview

org.apache.camel:camel-core is a versatile open-source integration framework based on known Enterprise Integration Patterns.

XML external entity (XXE) vulnerability in the XML converter setup in converter/jaxp/XmlConverter.java in Apache Camel before 2.13.4 and 2.14.x before 2.14.2 allows remote attackers to read arbitrary files via an external entity in an SAXSource.