Policy Bypass Affecting org.apache.cxf:cxf-bundle-minimal package, versions [2.4.5,2.4.8) [2.5.1,2.5.4) [2.6.0,2.6.1)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHECXF-536123
  • published 17 Jun 2014
  • disclosed 5 Jan 2013
  • credit Unknown

How to fix?

Upgrade org.apache.cxf:cxf-bundle-minimal to version 2.4.8, 2.5.4, 2.6.1 or higher.

Overview

org.apache.cxf:cxf-bundle-minimal is an open source services framework.

Affected versions of this package are vulnerable to Policy Bypass. It does not properly enforce child policies of a WS-SecurityPolicy 1.1 SupportingToken policy on the client side, which allows remote attackers to bypass the (1) AlgorithmSuite, (2) SignedParts, (3) SignedElements, (4) EncryptedParts, and (5) EncryptedElements policies.