Security Bypass Affecting org.apache.derby:derby Open this link in a new tab package, versions [10.3.1.4, 10.14.2.0)


0.0
medium
  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEDERBY-32274

  • published

    16 May 2018

  • disclosed

    7 May 2018

  • credit

    Gregory Draperi

How to fix?

Upgrade org.apache.derby:derby to version 10.14.2.0 or higher.

Overview

org.apache.derby:derby is a subproject of the Apache DB project.

Affected versions of this package are vulnerable to Security Bypass. A specially-crafted network packet can be used to request the Derby Network Server to boot a database whose location and contents are under the user's control.