Command Injection Affecting org.apache.directory.studio:org.apache.directory.studio.plugins-parent package, versions [,2.0.0.v20151221-M10)


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEDIRECTORYSTUDIO-536196

  • published

    21 Jun 2016

  • disclosed

    11 Apr 2016

  • credit

    Muhammad Shahmeer Amir

How to fix?

Upgrade org.apache.directory.studio:org.apache.directory.studio.plugins-parent to version 2.0.0.v20151221-M10 or higher.

Overview

org.apache.directory.studio:org.apache.directory.studio.plugins-parent is a directory tooling platform intended to be used with an LDAP server.

Affected versions of this package are vulnerable to Command Injection. The CSV export function does not properly escape field values, which might allow attackers to execute arbitrary commands by leveraging a crafted LDAP entry that is interpreted as a formula when imported into a spreadsheet.