Authentication Bypass Affecting org.apache.geode:geode-core Open this link in a new tab package, versions [,1.4.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEGEODE-31640

  • published

    6 Mar 2018

  • disclosed

    1 Feb 2018

  • credit

    Unknown

Introduced: 1 Feb 2018

CWE-592 Open this link in a new tab

How to fix?

Upgrade org.apache.geode:geode-core to version 1.4.0 or higher.

Overview

org.apache.geode:geode-core is a data management platform that provides real-time, consistent access to data-intensive applications throughout widely distributed cloud architectures.

Affected versions of this package are vulnerable to Authentication Bypass. The CacheClientProxy could be asked to authorize a message prior to receiving its security subject.