Information Exposure Affecting org.apache.hadoop:hadoop-hdfs Open this link in a new tab package, versions [,2.6.4) [2.7.0,2.7.2)


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEHADOOP-30631

  • published

    19 Dec 2016

  • disclosed

    19 Dec 2016

  • credit

    Kihwal Lee

How to fix?

Upgrade org.apache.hadoop:hadoop-hdfs to version 2.6.4, 2.7.2 or higher.

Overview

org.apache.hadoop:hadoop-hdfs is a framework that allows for the distributed processing of large data sets across clusters of computers using simple programming models.

Affected versions of this package are vulnerable to Information Exposure via the short-circuit reads feature of HDFS. A local user on an HDFS DataNode may be able to craft a block token that grants unauthorized read access to random files by guessing certain fields in the token.