Information Exposure Affecting org.apache.hive:hive-common Open this link in a new tab package, versions [1.2.0,2.2.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEHIVE-30638

  • published

    31 Oct 2016

  • disclosed

    31 Oct 2016

  • credit

    Unknown

Introduced: 31 Oct 2016

CWE-200 Open this link in a new tab

How to fix?

Upgrade org.apache.hive:hive-common to version 2.2.0 or higher.

Overview

org.apache.hive:hive-common is a reading, writing, and managing large datasets residing in distributed storage using SQL.

Affected versions of this package are vulnerable to Information Exposure. This vulnerability relates to a replay attack due to authenticating twice within a short period of time, when the context root is requested.