Access Restriction Bypass Affecting org.apache.hive:hive-exec package, versions [,2.3.4) [3.1.0, 3.1.1)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEHIVE-72580

  • published

    12 Nov 2018

  • disclosed

    8 Nov 2018

  • credit

    Mithun Radhakrishna

How to fix?

Upgrade org.apache.hive:hive-exec to version 2.3.4, 3.1.1 or higher.

Overview

org.apache.hive:hive-exec is a package for reading, writing, and managing large datasets residing in distributed storage using SQL.

Affected versions of this package are vulnerable to Access Restriction Bypass. Local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.