Information Exposure Affecting org.apache.hive.hcatalog:hive-hcatalog-core Open this link in a new tab package, versions [2.1,2.1.2) [2.2,2.2.1) [2.3.0,2.3.1)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEHIVEHCATALOG-31581

  • published

    9 Nov 2017

  • disclosed

    10 Jan 2017

  • credit

    Suja Santhosh

How to fix?

Upgrade org.apache.hive.hcatalog:hive-hcatalog-core to version 2.3.1 or higher.

Overview

org.apache.hive.hcatalog:hive-hcatalog-core the Apache Hive data warehouse software facilitates reading, writing, and managing large datasets residing in distributed storage using SQL.

Affected versions of the package are vulnerable to Information Disclosure. Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.