Arbitrary Code Execution Affecting org.apache.jena:jena-fuseki package, versions [2.0.0, 4.1.0)


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEJENA-1316204

  • published

    5 Jul 2021

  • disclosed

    5 Jul 2021

  • credit

    Luka Safonov

How to fix?

Upgrade org.apache.jena:jena-fuseki to version 4.1.0 or higher.

Overview

org.apache.jena:jena-fuseki is a Fuseki is a SPARQL 1.1 Server which provides the SPARQL query, SPARQL update and SPARQL graph store protocols.

Affected versions of this package are vulnerable to Arbitrary Code Execution via certain page views.