Arbitrary Command Execution Affecting org.apache.jspwiki:jspwiki-builder package, versions [,2.11.0)


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.46% (76th percentile)
Expand this section
NVD
9.1 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHEJSPWIKI-1925888
  • published 24 Nov 2021
  • disclosed 24 Nov 2021
  • credit haby0

How to fix?

Upgrade org.apache.jspwiki:jspwiki-builder to version 2.11.0 or higher.

Overview

org.apache.jspwiki:jspwiki-builder is a WikiWiki clone, written in Java and JSP.

Affected versions of this package are vulnerable to Arbitrary Command Execution by using a carefuly crafted HTTP request on logout, which may allow an attacker to delete arbitrary files in the system, given that those files are reachable to the user running the package.