Open Redirect Affecting org.apache.juddi:juddi-client package, versions [3.1.0, 3.2.0)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
Expand this section
NVD
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHEJUDDI-460999
  • published 12 Feb 2018
  • disclosed 19 May 2017
  • credit Unknown

How to fix?

Upgrade org.apache.juddi:juddi-client to version 3.2.0 or higher.

Overview

org.apache.juddi:juddi-client is a Java implementation of OASIS the Universal Description, Discovery, and Integration (UDDI) specification for (Web) Services.

Affected versions of this package are vulnerable to Open Redirect. An attacker may redirect the browser to an unintended web page.