Access Restriction Bypass Affecting org.apache.kylin:kylin-stream-coordinator Open this link in a new tab package, versions [,3.1.3)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEKYLIN-2331070

  • published

    6 Jan 2022

  • disclosed

    6 Jan 2022

  • credit

    Wei Lin Ngo

How to fix?

Upgrade org.apache.kylin:kylin-stream-coordinator to version 3.1.3 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass. All request mappings in StreamingCoordinatorController.java handling /kylin/api/streaming_coordinator/* REST API endpoints did not include any security checks, which allowed an unauthenticated user to issue arbitrary requests, such as assigning/unassigning of streaming cubes, creation/modification and deletion of replica sets, to the "Kylin" Coordinator.

** Note: ** For endpoints accepting node details in HTTP message body, unauthenticated (but limited) server-side request forgery (SSRF) can be achieved.