Man-in-the-Middle (MitM) Affecting org.apache.logging.log4j:log4j-core Open this link in a new tab package, versions [,2.13.2)


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHELOGGINGLOG4J-567761

  • published

    28 Apr 2020

  • disclosed

    27 Apr 2020

  • credit

    Unknown

How to fix?

Upgrade org.apache.logging.log4j:log4j-core to version 2.13.2 or higher.

Overview

org.apache.logging.log4j:log4j-core is a logging library for Java.

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM). Improper validation of certificate with host mismatch in Apache Log4j SMTP appender. This could allow an SMTPS connection to be intercepted by a man-in-the-middle attack which could leak any log messages sent through that appender.