Cryptographic Issues Affecting org.apache.myfaces.core:myfaces-impl package, versions [1.1.0,1.1.8) [1.2.0,1.2.9) [2.0.0,2.0.1)


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHEMYFACESCORE-536416
  • published 10 Jan 2014
  • disclosed 10 Jun 2010
  • credit Unknown

How to fix?

Upgrade org.apache.myfaces.core:myfaces-impl to version 1.1.8, 1.2.9, 2.0.1 or higher.

Overview

org.apache.myfaces.core:myfaces-impl is a The private implementation classes of the Apache MyFaces Core JSF-2.3 Implementation

Affected versions of this package are vulnerable to Cryptographic Issues as it uses an encrypted View State without a Message Authentication Code (MAC), which makes it easier for remote attackers to perform successful modifications of the View State via a padding oracle attack.