Information Exposure Affecting org.apache.nifi:nifi-security-utils Open this link in a new tab package, versions [1.10.0, 1.12.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHENIFI-1015373

  • published

    2 Oct 2020

  • disclosed

    2 Oct 2020

  • credit

    Unknown

How to fix?

Upgrade org.apache.nifi:nifi-security-utils to version 1.12.0 or higher.

Overview

org.apache.nifi:nifi-security-utils is a system to process and distribute data.

Affected versions of this package are vulnerable to Information Exposure. The NiFi stateless execution engine produced log output which included sensitive property values. When a flow was triggered, the flow definition configuration JSON was printed, potentially containing sensitive values in plaintext.