Cross-site Scripting (XSS) Affecting org.apache.nifi:nifi Open this link in a new tab package, versions [,0.7.4) [1.0.0,1.3.0)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHENIFI-31478

  • published

    31 Aug 2017

  • disclosed

    11 Jun 2017

  • credit

    Matt Gilman

How to fix?

Upgrade org.apache.nifi:nifi to version 0.7.4 or higher.

Overview

org.apache.nifi:nifi is an easy to use, powerful, and reliable system to process and distribute data.

Apache NiFi before 0.7.4 and 1.x before 1.3.0 need to establish the response header telling browsers to only allow framing with the same origin.