Information Exposure Affecting org.apache.nifi:nifi-lookup-services-bundle package, versions [1.3.0, 1.10.0)


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHENIFI-534982
  • published 19 Nov 2019
  • disclosed 12 Jun 2019
  • credit RunningSnail

How to fix?

Upgrade org.apache.nifi:nifi-lookup-services-bundle to version 1.10.0 or higher.

Overview

org.apache.nifi:nifi-lookup-services-bundle is a system to process and distribute data.

Affected versions of this package are vulnerable to Information Exposure. The XMLFileLookupService allows trusted users to inadvertently configure a potentially malicious XML file. The XML file has the ability to make external calls to services (via XXE) and reveal information such as the versions of Java, Jersey, and Apache that the NiFI instance uses.