Information Exposure Affecting org.apache.nifi:nifi-framework package, versions [1.3.0, 1.10.0)


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHENIFI-534985
  • published 19 Nov 2019
  • disclosed 29 May 2019
  • credit Mark Payne

How to fix?

Upgrade org.apache.nifi:nifi-framework to version 1.10.0 or higher.

Overview

org.apache.nifi:nifi-framework is a system to process and distribute data.

Affected versions of this package are vulnerable to Information Exposure. When updating a Process Group via the API, the response to the request includes all of its contents (at the top most level, not recursively). The response included details about processors and controller services which the user may not have had read access to.