Arbitrary Code Execution Affecting org.apache.openjpa:openjpa-kernel package, versions [1.0.0,1.2.3) [2.0.0,2.2.2)


0.0
high

Snyk CVSS

    Attack Complexity Low
NVD  high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHEOPENJPA-30692
  • published 8 Jun 2014
  • disclosed 11 Jul 2013
  • credit Unknown

Overview

org.apache.openjpa:openjpa-kernel The BrokerFactory functionality in Apache OpenJPA 1.x before 1.2.3 and 2.x before 2.2.2 creates local executable JSP files containing logging trace data produced during deserialization of certain crafted OpenJPA objects, which makes it easier for remote attackers to execute arbitrary code by creating a serialized object and leveraging improperly secured server programs.

References