Access Restriction Bypass Affecting org.apache.openmeetings:openmeetings-core package, versions [1.0.0,3.3.0)


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEOPENMEETINGS-31542

  • published

    30 Oct 2017

  • disclosed

    17 Jul 2017

  • credit

    Unknown

How to fix?

Upgrade org.apache.openmeetings:openmeetings-core to version 3.3.0 or higher.

Overview

org.apache.openemeetings:openmeetings-core is a module for OpenMeetings core and red5 related classes and services.

Affected versions of the package are vulnerable to Access Restriction Bypass. Apache OpenMeetings 1.0.0 updates user password in insecure manner.