Access Restriction Bypass Affecting org.apache.openmeetings:openmeetings-server Open this link in a new tab package, versions [1.0.0,3.3.0)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEOPENMEETINGS-31545

  • published

    30 Oct 2017

  • disclosed

    17 Jul 2017

  • credit

    Unknown

How to fix?

Upgrade org.apache.openmeetings:openmeetings-server to version 3.3.0 or higher.

Overview

org.apache.openmeetings:openmeetings-server is a module for OpenMeetings server assembly.

Affected versions of the package are vulnerable to Access Restriction Bypass. Apache OpenMeetings 1.0.0 has an overly permissive crossdomain.xml file. This allows for flash content to be loaded from untrusted domains.