SQL Injection Affecting org.apache.openmeetings:openmeetings-server package, versions [1.0.0,3.3.0)


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEOPENMEETINGS-31546

  • published

    30 Oct 2017

  • disclosed

    17 Jul 2017

  • credit

    Unknown

How to fix?

Upgrade org.apache.openmeetings:openmeetings-server to version 3.3.0 or higher.

Overview

org.apache.openmeetings:openmeetings-server is a module for OpenMeetings server assembly.

Affected versions of this package are vulnerable to SQL Injection. Apache OpenMeetings 1.0.0 is vulnerable to SQL injection. This allows authenticated users to modify the structure of the existing query and leak the structure of other queries being made by the application in the back-end.

You can read more about SQL Injection on our blog.

References