Cross-site Request Forgery (CSRF) Affecting org.apache.openmeetings:openmeetings-web Open this link in a new tab package, versions [1.0.0,3.3.0)


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEOPENMEETINGS-31551

  • published

    30 Oct 2017

  • disclosed

    17 Jul 2017

  • credit

    Unknown

How to fix?

Upgrade org.apache.openmeetings:openmeetings-web to version 3.3.0 or higher.

Overview

org.apache.openmeetings:openmeetings-web is a module for all Wicket based UI OpenMeetings components.

Affected versions of the package are vulnerable to Cross-site Request Forgery (CSRF). Apache OpenMeetings 1.0.0 is vulnerable to Cross-site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks.