Cryptographic Issues Affecting org.apache.openmeetings:openmeetings-web package, versions [1.0.0,3.3.0)


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.13% (47th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHEOPENMEETINGS-31552
  • published 30 Oct 2017
  • disclosed 17 Jul 2017
  • credit Unknown

How to fix?

Upgrade org.apache.openmeetings:openmeetings-web to version 3.3.0 or higher.

Overview

org.apache.openmeetings:openmeetings-web is a module for all Wicket based UI OpenMeetings components.

Affected versions of the package are vulnerable to Cryptographic Issues. Apache OpenMeetings 1.0.0 uses not very strong cryptographic storage, captcha is not used in registration and forget password dialogs and auth forms missing brute force protection.