Access Restriction Bypass Affecting org.apache.openmeetings:openmeetings-web package, versions [3.2.0,3.3.0)


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
8.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHEOPENMEETINGS-31553
  • published 30 Oct 2017
  • disclosed 17 Jul 2017
  • credit Unknown

How to fix?

Upgrade org.apache.openmeetings:openmeetings-web to version 3.3.0 or higher.

Overview

org.apache.openmeetings:openmeetings-web is a module for all Wicket based UI OpenMeetings components.

Affected versions of the package are vulnerable to Access Restriction Bypass. Apache OpenMeetings 3.2.0 is vulnerable to parameter manipulation attacks, as a result attacker has access to restricted areas.